Site Access Requirements

INSPIRE Environmental Popup Maps require Adobe Flash Player version 10.0.2 or higher. This content is best viewed in Google Chrome web browser with Microsoft Windows 7 or higher.

Get Flash

Flash Player Help

Alternate content formats may be available upon request. If Adobe Flash Player is restricted by your business or agency, please contact info@INSPIREenvironmental.com to request alternate map formats.

Frequently Asked Questions

Why isn’t my file loading?
Popup maps are large files and can take a long time to load over slow connections.  Be patient and the file should load.  If you do not see a preloader on screen then you may need to download or update Adobe Flash Player.  You can test your flash player here.

How can I zoom in on the map?
By right clicking the content and choosing “Zoom In” the user can view a close-up of the area surrounding the curser position. Alternatively, Windows users can press the Windows key and “+” to magnify ther desktop.